読者です 読者をやめる 読者になる 読者になる

ソースからビルドしたrubygemsで失敗

Ruby

Ruby-1.9.1をソースからビルドしてgemコマンドを実行したところエラーメッセージが出て失敗。どうもzlib関連のモジュールの問題らしい。

結局zlibのヘッダファイルなどがなかったためRubyのビルド時に有効になっていなかったのが原因ぽい。zlibの開発用パッケージ(たいていのディストリビューションではzlib-develという名前)を入れてRubyを再ビルド・インストールしたらうまくいった。

configureがあるのだからそこでチェックして警告かエラーメッセージを出して欲しいかも。