読者です 読者をやめる 読者になる 読者になる

ソースからビルドしたrubygemsで失敗

Ruby-1.9.1をソースからビルドしてgemコマンドを実行したところエラーメッセージが出て失敗。どうもzlib関連のモジュールの問題らしい。結局zlibのヘッダファイルなどがなかったためRubyのビルド時に有効になっていなかったのが原因ぽい。zlibの開発用パッケ…

Ruby-1.9.0リリース

Ruby-1.9.0がリリースされたようです。クリスマスリリースの予定がちょっとだけ遅れて日付が変わってしまったようですが、リリースおめでとうございます。 なにはともあれ、とりあえずインストール。環境はVine Linux 4.1 on VMware-6。 # ./configure --ena…

Emacsのruby-mode.elってどこだっけ

Emacsにはデフォルトでたくさんのmodeが用意されてるけど、ruby-modeは入ってない。Ruby本体のソースのruby-1.8.?/misc以下にあるし、たいていのLinuxディストリビューションにはパッケージが用意されているけど、Windowsバイナリ+Meadow環境だとちょっと面…